AdSense表示回数激減!「サイトごと」自動広告はダメ?月10000PVでも1日1円【Cocoon】

ブログ
スポンサーリンク

おかげさまで月間10000PVを達成し、これからはサーバー代は広告料で賄えるかな、と期待が膨らんだのもつかの間、突然ほとんど収益が出ない日々が訪れました。

以前はクリックが全く無い日でも1日に少なくとも10円以上は収益があったのですが、突然1日0~1円、といった日が続きました。

今までも突然収益が激減することはありましたが、1週間以内には元に戻りました。

なぜ突然収益が減るのか、原因は良く分かりませんが、1日300PV程度のサイトだと魅力が薄く、広告が付かない(表示されない)日があるのも仕方が無いのかな、と考えていました。

今回も1週間もすれば元に戻るだろう、くらいに高を括っていたのですが、1週経っても2週経っても元に戻りません。気づくとほとんど広告が表示されない(収益が出ない)日が2か月続きました。(下図黄色枠部分)

AdSense 表示回数が激減かつ停滞が2か月

ページビュー(PV)はむしろ増えているのに、広告の表示回数が減った状態が続くのはさすがに変です。解消すべく、調べてみました。

スポンサーリンク

広告主が離れた?ポリシー違反も最適化案も無し

ポリシー違反は無い

まず疑ったのが私のサイトがポリシー違反を犯して懲罰の対象になっている?ということでした。

Google AdSense で 「ポリシーセンター」を確認します。

Google AdSense ポリシーセンター

「問題は検出されませんでした」です。問題ありません。

最適化案もなし

では、AdSense の広告の貼り方に何か問題があるのかな?と、すがる思いで「最適化」を確認してみました。

Google AdSense 最適化

「現在、最適化案はありません」です。

無いんかい!こんなに困っているのに…。最適化、あまり当てになりませんね。

広告主に嫌われた?

サイトの質が下がった、と広告主に判断されたのでしょうか?

今回の広告表示数の激減は2021年7月1日に始まっていました。この日に何かあったのでしょうか。

サイトの記事を見返しましたが、7月1日頃に何か特異な記事を投稿したわけでもありません。

原因が思い当たりません。手詰まりです…。

「サイトごと自動広告」が原因?

今までは「サイトごと」自動広告を利用

私は Google AdSense 合格後よりずっと「サイトごと」の自動広告を利用していました。

サイトごとの自動広告

「サイトごと」の広告掲載の「コードを取得」し、Cocoon設定「アクセス解析・認証」タブの”ヘッド用コード”欄に設定していました。

少なくとも2021年7月になるまではこの方法で何の問題もありませんでした。

全面広告とアンカー広告しか表示されない

しかし、現に広告表示が激減しています。表示されるのはホームページの下部に表示されるアンカー広告と、ホームページより選択した記事に遷移する際に表示される「全面広告」のみです。

ホームページ下部アンカー広告
全面広告

いずれの広告もホームページを訪れた人にしか表示されません。

ダイレクトに記事を検索して訪れてくれた人には広告が表示されないのです。広告表示数が激減するわけですね。

「サイトごと自動広告」が原因なのかどうかは不明でしたが、とにかく何かを変えないと現状から抜け出せないため、広告の設定を見直すことにしました。

広告ユニットごと「ディスプレイ広告」で解決

Cocoon開発者のわいひらさんのサイトでは「ディスプレイ広告」の設定が紹介されています。

広告(AdSense)を手っ取り早く設定する方法
Cocoonテーマ利用時における、最も簡単なAdSense広告設定方法の紹介です。
広告コードごと「ディスプレイ広告」

Cocoonでは「広告」タブの”広告コード”欄1箇所に「ディスプレイ広告」で取得したコードを貼り付けるだけです。

手間は「サイトごと自動広告」と変わりません。なぜ当時「ディスプレイ広告」にしなかったのかは思い出せませんが、Googleが自動広告推しなので自動広告を選んだ気がします。

「ディスプレイ広告」に変更してみました。

するとどうでしょう!数分のうちに各記事に広告が表示されるようになりました。

「ディスプレイ広告」 だと各記事に広告が表示された

1日の表示回数を見てみます。元の水準以上に回復しました!

表示回数が復活

まとめ

「サイトごと自動広告」 はサイトにコードを 1 つ追加するだけで、ページ内の広告掲載に適した場所を Google がもれなく検出し、自動的に広告を表示してくれるのがウリです。

しかし、どうも Cocoon とは相性が悪そうです。少なくとも2021年7月1日以降は 「サイトごと自動広告」 の仕様が変わったのか、各記事に広告が表示されなくなってしまいました。

もしかすると私の環境や記事のレイアウトによりたまたま発生した現象なのかもしれませんが、もし同じように 「サイトごと自動広告」 で広告表示が激減した場合は、 「ディスプレイ広告」 に切り替えることで解消するかもしれません。

コメント

タイトルとURLをコピーしました