【LinkStation】共有フォルダが開けない…初期化で復活!PC連動しない…ワークグループ設定で復活!

PC

LinkStationで共有フォルダーが開けない場合の対応として、①SMB1.0の設定、②Windows資格情報の登録、が挙げられていますが、これを行っても共有フォルダーが開けない事態に遭遇しました。

結果的にはLinkStation のWeb設定画面で「初期化」を行い解決しました。

共有フォルダーは開けるようになりましたが、PC連動電源機能(PCの起動・終了に連動してLinkStationが自動で起動・終了する機能)が機能しない、といった現象も発生しました。

こちらはWeb設定画面のネットワーク「ワークグループ」の設定を行うことで解決しました。

その経緯や対応について、LinkStationのHDD交換方法も含めメモしておきます。

古いWeb設定画面での説明ですが、新しいLinkStationにおいてもやっていることはそれほど変わらないと思いますので、読み替えてください。

きっかけはハードディスクの故障

10年以上使っているLinkStationがとうとう壊れました。

故障時の症状として、まずPC連動電源機能が効かなくなっており、PCに連動して電源が切れなくなりました。

ディスクにガリガリとアクセスしている状態が24時間、3~4日は続いていたようです。本体はだいぶ温かくなっていました。

LinkStationの電源が切れていないことに気づいて、手動でスイッチを長押ししてOFFにしようとしたのですが切れません。仕方がないので、電源コードを抜いて無理やり終了をしました。

手動でLinkStationのスイッチを入れると起動はしますが、PCに連動しての自動起動はやはりできませんでした。そして、やはり終了できません。

NAS Navigator2やWeb設定画面には特にエラーや異常は表示されていませんでした。

とうとう壊れたかな?と買い替えるつもりで初めてLinkStationを分解してみました。といっても、説明書に従い筐体を開きハードディスクを外しただけです。とてもシンプルな作りであることが分かりました。

それ以上分解できそうな所もないので元に戻し、LinkStationのスイッチを入れたところ、NAS Navigator2に警告が出ました。

NAS Savitagor2エラー

Web設定画面を開くと、「RAIDアレイ1にエラーが発生しました」と表示されています。

Web設定画面 警告表示

どうやら2台のHDDの1台が故障したようです。

RAID設定 エラー表示

LinkStationのHDD交換については公式ホームページにも掲載されていますし、先人たちのサイトに色々と載っています。RAID1(ミラーリング)で構成している場合、壊れたHDDを入れ替えてWeb管理画面から「RAIDの再構成」を選ぶだけで、もう一方のHDDからデータをコピーして復旧するようです。簡単そうです。

LinkStationのHDDを交換しRAIDアレイを再構成

まず壊れたHDDを交換する必要があります。

先人達は純正以外のバルク品で再構成した実績もあるようです。

信頼性の高いHDD、例えばWesternDegitalのREDシリーズを使うべき、というサイトもありましたが、個人で使う分にはRAID1ですしHDD単体にそこまでの信頼性は必要ないかな、と感じました。壊れたらまた取り換えよう、くらいの気持ちです。2台のHDDが同時に壊れない限り大丈夫です。

しかも、USBハードディスクにもバックアップを取る環境を構築しているので、万が一2台同時に壊れても復旧できます。3台同時の可能性は限りなく低いでしょう。

バックアップの必要性

壊れてみて改めて感じましたが、RAID1と言えどもバックアップは必要ですね。RAID1のHDDが1台が壊れると残りは1台のみです。この1台も壊れてしまったら…、と急に不安になります。バックアップを取っていると安心感が違います。おすすめします。

HDD交換後のRAID1再構成手順

先人たちのサイトを見ると、元々の容量以上のSATAのHDDであれば大丈夫そうだったので、あまり深く考えずドスパラで一番安い1TBのHDDを購入しました。

TOSHIBA DT01ACA100 バルク (1TB) 3.5インチ 3,611円(+税)

壊れたHDDと交換し、再構築を行います。以下はその手順です。HDDの容量にもよると思いますが、6時間くらいの作業です。

HDD交換後の「RAID設定」画面

交換後のHDDであるDT01ACA100が表示され、選択して「RAIDアレイの再構成」をしてね、というエラーが表示されます。

HDD交換後のディスク管理画面

交換後のHDDを選択し「RAIDアレイの再構成」

交換したHDDをチェックし「RAIDアレイの再構成」を選択します。

「RAIDアレイの再構成」を選択

再構成確認

本当に再構築するの?と確認されます。確認番号を入力し「設定」を選択します。

再構成確認画面

RAIDアレイ再構成中

RAIDアレイの再構成は数分で完了します。

RAIDアレイの再構成中

RAIDアレイ再構成完了

再構成が完了すると完了したことを知らせてくれます。RAIDの修復は始まっています。「了解」を押すとTOP画面に戻ります。

RAIDアレイの再構成完了

RAIDアレイ修復を知らせるTOP画面

TOP画面には「RAIDアレイ1を修復しています」と表示されます。リンクを選択すると進捗状況が表示されます。

RAIDアレイ修復中のTOP画面

RAIDアレイ修復中の進捗状況を表す「ディスク情報」

正常なHDDから交換した新しいHDDへ情報がコピーされ修復されます。進捗状況が表示され、最初は3時間程度で終わるように見えるのですが、処理が進み残り時間の精度が上がるつれ残り時間が増えていきます。一晩はかかると思って寝た方が良いです。1TBのHDDだと6時間くらいかかりました。(寝たので正確には分かりません)

RAIDアレイ修復中のディスク管理画面

普通はこれでNAS(LinkStation)が復旧します。しかし、私の場合はこれで済みませんでした。

問題発生!!共有フォルダーが開けない!

復旧後NAS Navigator2

NAS Navigator2を見る限り警告マークも消え復活したように見えました。喜んで共有フォルダーを開こうとしたのですが、何の反応もありません。共有フォルダーが開けないのです。

Web設定画面は開けます。設定を一通り見たのですが、特にエラーや警告もなく何の問題もなさそうです。が、共有フォルダーは開けないのです。

Googleで検索してみたのですが、①SMB1.0の設定、②Windows資格情報の登録、といった対応以外に有用な情報は見つけられませんでした。

やはり新しく購入しなきゃダメなのか?と半ば諦めつつ、最後の手段で「初期化」を試してみることにしました。

初期化の手順

NAS本体のスイッチで初期化する方法もあるようですが、私はWeb設定画面から初期化しました。

初期化画面

初期化するとデータもすべて消去されるのかと覚悟していたのですが、初期化されるのは設定情報のみです。初期化してもデータは消えません。

それを知らず、私はデータが消えるのが嫌で試しに古いHDD(壊れたHDD)に戻してから初期化してみました。

壊れたHDDでも初期化は完了し、その後にRAIDの再構成(6時間)を行ってみると何事もなく完了しました。

「もしかしてHDDが壊れたわけではなかった?」と喜びましたが、NAS Navigator2で共有フォルダーを開くとやはり「RAIDアレイ1にエラーが発生しました」に戻ってしまいました。

でも、エラーは出つつも共有フォルダーは開けました!

共有フォルダーが復活!

やはりHDDは壊れていたのね、と諦め、新しく購入したDT01ACA100(再構成済み)に戻しました。既に再構成済みですし、これで復旧し共有フォルダーも開けるはず、と期待したのですが、なんと、また「RAIDアレイ1にエラーが発生しました」状態になっていまいました…。一度壊れたHDDに戻したのでエラーの状態が記憶されてしまった?!

仕方が無いので、改めてまたRAIDの再構成(6時間)を行ったところ、やっと新しいHDD(DT01ACA100)で共有フォルダーが開ける状態になりました!

途中、壊れたHDDに戻して初期化する、といった余計な事をしてしまったため、紆余曲折して最短の復旧方法が良く分からなくなってしまいましたが、初期化が共有フォルダーを開けるきっかになったことは確かです。

もしかすると、新しいHDD(DT01ACA100)でRAID再構成後にそのまま初期化すれば最短で共有フォルダーを開ける状態になったかもしれません。

問題発生!!PC連動機能が機能しない!

これで壊れたLinkStationが復活!と喜んだのも束の間、まだ苦難は続きます。

私のLinkStation LS-WTGL/R1には「PC連動機能」があり、同じネットワーク上にあるPCの電源ON/OFFに連動し、LS-WTGL/R1の電源も自動でON/OFFになる、という優れた機能があります。

この機能が効かなくなっていました。

NAS Navigator2にLS-WTGL/R1のアイコンは表示されるし、Web設定画面も開けます。共有フォルダーも開けるようになりました。PCと同じネットワークにあることは間違いないのですが、それを検知できないようです。

そこで、明示的に「ワークグループ」を設定してみました。

LinkStationにワークグループを設定

ワークグループ設定

まずLinkStation LS-WTGL/R1 にワークグループを設定します。

Web管理画面の「ネットワーク」−「ワークグループ設定」画面にてワークグループ名に任意の名称(”SKYNET”)を設定します。

その後、PCのワークグループも”SKYNET”に設定しました。

Windows10ワークグループの設定方法

スタートメニューを右クリックしシステムメニューを選択

システムメニューを選択

システム設定「バージョン情報」の「システム情報」を選択

システム情報を選択

システムの「設定の変更」を選択

システムの設定の変更

システムのプロパティの「変更」を選択

システムのプロパティ

ワークグループを変更

コンピュータ名/ドメイン名の変更

PCのワークグループを変更すると、再起動が求められるので、再起動します。

PC連動機能が復活!!

PCの電源をONにし、Windowsにログインします。すると…連動してLS-WTGL/R1も起動しました!

PCの電源をOFFにします。すると、5分くらいしてLS-WTGL/R1の電源も切れました。

見事復活です!長かった…。

ちなみに、ワークグループ名を初期値の”WORKGROUP”に戻すとやはり連動しなくなってしまいました。以前はこんな事は無かったはずなんですが…。やはり何かは壊れてしまったのかもしれません。

まとめ

LinkStationで共有フォルダーが開けない(LinkStationにアクセスできない)場合はの、①SMB1.0の設定、②Windows資格情報の登録、でほぼ解消するはずですが、それでも開けない場合は「初期化」で開けるようになるかもしれません。

LinkStationのPC連動機能が効かなくなった場合は、「ワークグループ」を設定する事で解消できるかもしれません。

長い戦いでしたが、これでまたLinkStationが使えるようになりました。

ちなみに現在は元々の500GBのハードディスクと新しい1TBのRAID1(ミラーリング)で動いているため、500GBしか認識しません。せっかくなので、もう1台DT01ACA100(1TB)を購入して1TBのRAID1にしようと思います。

HDD交換で簡単に容量を増やしていけるなんてステキですね!

10年以上前のLinkStationですが、まだまだ使えそうです。

ぱんはげ
ぱんはげ

その後、もう1台DT01ACA100 (1TB)を購入し、「RAIDアレイの再構成」を行いました。これで1TBのRAID1になるのかと思ったら、容量は500GBのまま…。元が500GBのRAID1なのでハードディスクを1TBにしてもRAIDの容量は変わらないんですね。

1TBのRAIDにするためにはこの状態で一度「RAIDアレイの削除」を行い、「RAIDアレイの作成」をし直す必要があるようです。データは消えてしまうのでバックアップが必要です。

詳しい容量アップの手順はまさにいの日記にありました。私は18.の手順で止まっている状態です。バックアップはありますが、データが消えると思うとちょっと躊躇しますね。

だるま犬
だるま犬

新しいLS510DNBシリーズのマニュアルには「RAIDアレイの容量を拡張する」機能の説明があって、データを消さずにRAIDの容量を拡張できるみたい。うらやましいね。

RAIDアレイ再作成後1TBを認識
ぱんはげ
ぱんはげ

「RAIDアレイの削除」を行い、「RAIDアレイの作成」をし直しました。1TBを認識したよ!ただし、バックアップからのコピーに1日がかり。バックアップからのコピーはLinkStation単体ではできないのでPCを使う必要があります。PCの電源もコピーが終わるまで落とせないのが玉にきずだね。

コメント

タイトルとURLをコピーしました